summaryrefslogtreecommitdiff
path: root/packages/scripting-languages
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2012-04-23 22:37:18 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2012-04-23 22:37:18 +0200
commit0b086c1e8caac2b1b2b94d4d6ddb95053c18ae76 (patch)
tree774d830c29f621dcb190ae87f17a57a794edefcd /packages/scripting-languages
parent898d16bd62f51b3dce905c3238386122963db8ee (diff)
downloadembtoolkit-0b086c1e8caac2b1b2b94d4d6ddb95053c18ae76.tar.gz
embtoolkit-0b086c1e8caac2b1b2b94d4d6ddb95053c18ae76.tar.bz2
embtoolkit-0b086c1e8caac2b1b2b94d4d6ddb95053c18ae76.tar.xz
Packages: lua modules: add rings-1.2.3
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/scripting-languages')
-rw-r--r--packages/scripting-languages/lua-modules/rings/rings.kconfig50
-rw-r--r--packages/scripting-languages/lua-modules/rings/rings.mk52
-rw-r--r--packages/scripting-languages/scripting-languages.kconfig1
-rw-r--r--packages/scripting-languages/scripting-languages.mk3
4 files changed, 106 insertions, 0 deletions
diff --git a/packages/scripting-languages/lua-modules/rings/rings.kconfig b/packages/scripting-languages/lua-modules/rings/rings.kconfig
new file mode 100644
index 0000000..32c4509
--- /dev/null
+++ b/packages/scripting-languages/lua-modules/rings/rings.kconfig
@@ -0,0 +1,50 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2012 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file rings.kconfig
+# \brief rings.kconfig of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date April 2012
+################################################################################
+
+config EMBTK_HAVE_RINGS
+ bool "Have Rings module"
+ depends on EMBTK_HAVE_LUA
+ select EMBTK_RINGS_NEED_PATCH
+ help
+ Rings is a library which provides a way to create new Lua states
+ from within Lua. It also offers a simple way to communicate
+ between the creator (master) and the created (slave) states.
+
+choice
+ prompt "Rings version you wish"
+ depends on EMBTK_HAVE_RINGS
+ help
+ Here you can choose which version of Rings you want to use.
+
+ config EMBTK_RINGS_VERSION_1_2_3
+ bool "rings-1.2.3"
+endchoice
+
+config EMBTK_RINGS_VERSION_STRING
+ string
+ default "1.2.3" if EMBTK_RINGS_VERSION_1_2_3
+
+config EMBTK_RINGS_NEED_PATCH
+ bool
diff --git a/packages/scripting-languages/lua-modules/rings/rings.mk b/packages/scripting-languages/lua-modules/rings/rings.mk
new file mode 100644
index 0000000..d353627
--- /dev/null
+++ b/packages/scripting-languages/lua-modules/rings/rings.mk
@@ -0,0 +1,52 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2012 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file rings.mk
+# \brief rings.mk of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date April 2012
+################################################################################
+
+RINGS_NAME := rings
+RINGS_VERSION := $(call embtk_get_pkgversion,rings)
+RINGS_SITE := https://github.com/downloads/keplerproject/rings
+RINGS_PACKAGE := rings-$(RINGS_VERSION).tar.gz
+RINGS_SRC_DIR := $(PACKAGES_BUILD)/rings-$(RINGS_VERSION)
+RINGS_BUILD_DIR := $(PACKAGES_BUILD)/rings-$(RINGS_VERSION)
+
+RINGS_LIBS =
+
+RINGS_DEPS = lua_install
+
+RINGS_MAKE_OPTS = PREFIX=$(SYSROOT)/usr/ LIBDIR=$(LIBDIR)
+RINGS_MAKE_OPTS += CC=$(TARGETCC_CACHED)
+RINGS_MAKE_OPTS += LDFLAGS="-L$(SYSROOT)/$(LIBDIR) -L$(SYSROOT)/usr/$(LIBDIR)"
+RINGS_MAKE_OPTS += CFLAGS="$(TARGET_CFLAGS) -I$(SYSROOT)/usr/include"
+
+rings_install:
+ $(call embtk_makeinstall_pkg,rings)
+
+define embtk_postinstall_rings
+ $(Q)mkdir -p $(ROOTFS)
+ $(Q)mkdir -p $(ROOTFS)/usr
+ $(Q)mkdir -p $(ROOTFS)/usr/$(LIBDIR)
+ $(Q)mkdir -p $(ROOTFS)/usr/share
+ $(Q)cp -R $(SYSROOT)/usr/$(LIBDIR)/lua $(ROOTFS)/usr/$(LIBDIR)/
+ $(Q)cp -R $(SYSROOT)/usr/share/lua $(ROOTFS)/usr/share/
+endef
diff --git a/packages/scripting-languages/scripting-languages.kconfig b/packages/scripting-languages/scripting-languages.kconfig
index 3fe0966..ddbe38d 100644
--- a/packages/scripting-languages/scripting-languages.kconfig
+++ b/packages/scripting-languages/scripting-languages.kconfig
@@ -29,6 +29,7 @@ comment "------------------------------------"
comment "---- Lua Modules"
comment "------------------------------------"
source packages/scripting-languages/lua-modules/luafilesystem/luafilesystem.kconfig
+source packages/scripting-languages/lua-modules/rings/rings.kconfig
# microperl
source packages/scripting-languages/perl/perl.kconfig
diff --git a/packages/scripting-languages/scripting-languages.mk b/packages/scripting-languages/scripting-languages.mk
index a989eaf..0f40f78 100644
--- a/packages/scripting-languages/scripting-languages.mk
+++ b/packages/scripting-languages/scripting-languages.mk
@@ -30,6 +30,9 @@ ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_LUA) += lua_install
include $(EMBTK_ROOT)/packages/scripting-languages/lua-modules/luafilesystem/luafilesystem.mk
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_LUAFILESYSTEM) += luafilesystem_install
+include $(EMBTK_ROOT)/packages/scripting-languages/lua-modules/rings/rings.mk
+ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_RINGS) += rings_install
+
#microperl
include $(EMBTK_ROOT)/packages/scripting-languages/perl/perl.mk
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_MICROPERL) += microperl_install