summaryrefslogtreecommitdiff
path: root/packages/security
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2012-05-23 21:52:00 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2012-05-23 21:52:58 +0200
commit6a34c9370c1c16d72c84062f84c163c70d2f4ae0 (patch)
tree666912d20765b971cdead00d10d2190f62a7e032 /packages/security
parentc421f6d63cd8e808247c0681b61b30898b6f7c61 (diff)
downloadembtoolkit-6a34c9370c1c16d72c84062f84c163c70d2f4ae0.tar.gz
embtoolkit-6a34c9370c1c16d72c84062f84c163c70d2f4ae0.tar.bz2
embtoolkit-6a34c9370c1c16d72c84062f84c163c70d2f4ae0.tar.xz
New package: Iptables: include it in the build system and little tweak
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/security')
-rw-r--r--packages/security/iptables/iptables.kconfig26
-rw-r--r--packages/security/iptables/iptables.mk21
-rw-r--r--packages/security/security.kconfig7
-rw-r--r--packages/security/security.mk9
4 files changed, 29 insertions, 34 deletions
diff --git a/packages/security/iptables/iptables.kconfig b/packages/security/iptables/iptables.kconfig
index 1326eef..1852cf8 100644
--- a/packages/security/iptables/iptables.kconfig
+++ b/packages/security/iptables/iptables.kconfig
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C)
+# Copyright(C) 2012 Averell KINOUANI <a.kinouani@voila.fr>
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -26,30 +26,30 @@
config EMBTK_HAVE_IPTABLES
bool "Have Iptables"
select KEMBTK_UCLIBC_UCLIBC_HAS_FLOATS if EMBTK_CLIB_UCLIBC
- select KEMBTK_UCLIBC_DO_C99_MATH if EMBTK_CLIB_UCLIBC
+ select KEMBTK_UCLIBC_DO_C99_MATH if EMBTK_CLIB_UCLIBC
help
iptables is the userspace command line program used to configure
- the Linux 2.4.x and 2.6.x IPv4 packet filtering ruleset. It is
- target towards system administrators. Since Network Address Translation
- is also configured from the packet filter ruleset, iptables is used for
- this, too.
+ the Linux 2.4.x and 2.6.x IPv4 packet filtering ruleset.
+ It is target towards system administrators.
+ Since Network Address Translation is also configured from the
+ packet filter ruleset, iptables is used for Sthis, too.
+
choice
prompt "Iptables version you wish"
depends on EMBTK_HAVE_IPTABLES
help
Here you can choose which version of iptables you want to use.
config EMBTK_IPTABLES_VERSION_1_4_13
- bool "iptables-1.4.13"
+ bool "iptables-1.4.13"
endchoice
-
config EMBTK_IPTABLES_HAVE_LIBIPQ
bool "Have Libipq"
- select EMBTK_HAVE_IPTABLES
+ depends on EMBTK_HAVE_IPTABLES
help
- libipq is a developpement library for iptables userspace packet queuing.
- libipq provides an API for communicating with ip_queue.
+ libipq is a developpement library for iptables userspace packet
+ queuing. libipq provides an API for communicating with ip_queue.
config EMBTK_IPTABLES_VERSION_STRING
string
@@ -59,7 +59,3 @@ config EMBTK_IPTABLES_NEED_PATCH
bool
config EMBTK_IPTABLES_NEED_AUTORECONF
bool
-config EMBTK_IPTABLES_PKG_IS_TARGZ
- bool
-config EMBTK_IPTABLES_PKG_IS_TARBZ2
- bool
diff --git a/packages/security/iptables/iptables.mk b/packages/security/iptables/iptables.mk
index f5efe6e..e42523d 100644
--- a/packages/security/iptables/iptables.mk
+++ b/packages/security/iptables/iptables.mk
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2009-2011 Abdoulaye Walsimou GAYE.
+# Copyright(C) 2012 Averell KINOUANI <a.kinouani@voila.fr>
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -25,24 +25,17 @@
IPTABLES_NAME := iptables
IPTABLES_VERSION := $(call embtk_get_pkgversion,iptables)
-IPTABLES_SITE := ftp://ftp.netfilter.org/pub/iptables/
-#IPTABLES_SITE_MIRROR3 := ftp://ftp.embtoolkit.org/embtoolkit.org/packages-mirror
+IPTABLES_SITE := ftp://ftp.netfilter.org/pub/iptables
IPTABLES_PACKAGE := iptables-$(IPTABLES_VERSION).tar.bz2
IPTABLES_SRC_DIR := $(PACKAGES_BUILD)/iptables-$(IPTABLES_VERSION)
IPTABLES_BUILD_DIR := $(PACKAGES_BUILD)/iptables-$(IPTABLES_VERSION)
-IPTABLES_BINS :=
-IPTABLES_SBINS := iptables ip6tables ip6tables-restore ip6tables-save iptables-restore iptables-save
-IPTABLES_INCLUDES := ipt_kernel_headers.h libip6tc.h libiptc.h libxtc.h xtables.h xtcshared.h
-IPTABLES_LIBS := libip4tc.so.0 libip4tc.so.0 libxtables.so.7
-IPTABLES_LIBEXECS :=
-IPTABLES_PKGCONFIGS :=
+IPTABLES_SBINS := iptables ip6tables ip6tables-restore ip6tables-save
+IPTABLES_SBINS += iptables-restore iptables-save
+IPTABLES_INCLUDES := ipt_kernel_headers.h libip6tc.h libiptc.h
+IPTABLES_INCLUDES += libxtc.h xtables.h xtcshared.h
+IPTABLES_LIBS := libip4tc.so.0 libip4tc.so.0 libxtables.so.7
-IPTABLES_CONFIGURE_ENV :=
ifeq ($(CONFIG_EMBTK_IPTABLES_HAVE_LIBIPQ),y)
IPTABLES_CONFIGURE_OPTS := --enable-libipq
endif
-IPTABLES_MAKE_OPTS :=
-IPTABLES_MAKE_DIRS :=
-
-IPTABLES_DEPS :=
diff --git a/packages/security/security.kconfig b/packages/security/security.kconfig
index a44aeb4..c23f3fe 100644
--- a/packages/security/security.kconfig
+++ b/packages/security/security.kconfig
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2010-2011 GAYE Abdoulaye Walsimou.
+# Copyright(C) 2010-2012 GAYE Abdoulaye Walsimou.
# For Copyrright from linux kernel's build/configure system, see their source
# code.
#
@@ -24,5 +24,8 @@
# \date February 2010
################################################################################
-source packages/security/openssl/openssl.kconfig
+# Iptables
+source packages/security/iptables/iptables.kconfig
+# OpenSSL
+source packages/security/openssl/openssl.kconfig
diff --git a/packages/security/security.mk b/packages/security/security.mk
index ff32182..05fc349 100644
--- a/packages/security/security.mk
+++ b/packages/security/security.mk
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2010-2011 Abdoulaye Walsimou GAYE.
+# Copyright(C) 2010-2012 Abdoulaye Walsimou GAYE.
#
# This program is free software; you can distribute it and/or modify it
# under the terms of the GNU General Public License
@@ -22,7 +22,10 @@
# \date February 2010
################################################################################
-#OpenSSL
+# Iptables
+include $(EMBTK_ROOT)/packages/security/iptables/iptables.mk
+ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_IPTABLES) += iptables_install
+
+# OpenSSL
include $(EMBTK_ROOT)/packages/security/openssl/openssl.mk
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_OPENSSL) += openssl_install
-