summaryrefslogtreecommitdiff
path: root/packages/development/boost
diff options
context:
space:
mode:
Diffstat (limited to 'packages/development/boost')
-rw-r--r--packages/development/boost/boost.kconfig2
-rw-r--r--packages/development/boost/boost.mk3
2 files changed, 3 insertions, 2 deletions
diff --git a/packages/development/boost/boost.kconfig b/packages/development/boost/boost.kconfig
index 6e75522..2265cd8 100644
--- a/packages/development/boost/boost.kconfig
+++ b/packages/development/boost/boost.kconfig
@@ -25,7 +25,7 @@
config EMBTK_HAVE_BOOST
bool "Have boost"
- select EMBTK_HAVE_GETTEXT
+ select EMBTK_HAVE_GETTEXT-INTL
select EMBTK_HAVE_BZIP2
select EMBTK_HAVE_ZLIB
select EMBTK_GCC_LANGUAGE_CPP
diff --git a/packages/development/boost/boost.mk b/packages/development/boost/boost.mk
index aaf7eac..2da223f 100644
--- a/packages/development/boost/boost.mk
+++ b/packages/development/boost/boost.mk
@@ -53,7 +53,8 @@ BOOST_MAKE_OPTS += boost.locale.posix=off
endif
BOOST_DEPS-$(CONFIG_EMBTK_BOOST_WITH_ICU) := icu_install
-BOOST_DEPS := zlib_install bzip2_install gettext_install $(BOOST_DEPS-y)
+BOOST_DEPS := zlib_install bzip2_install gettext-intl_install
+BOOST_DEPS += $(BOOST_DEPS-y)
# FIXME: consider using clang++ when libc++ will be fully integrated
embtk_boost_cxx = using gcc : $(shell $(TARGETGCC) -dumpversion) : $(TARGETGCXX_CACHED)