summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael J. Spencer <bigcheesegs@gmail.com>2010-09-10 21:14:25 +0000
committerMichael J. Spencer <bigcheesegs@gmail.com>2010-09-10 21:14:25 +0000
commit4e9c939312ff73bd0c6a6485fd5f97012f5910fa (patch)
tree5ac7e42fde2303030a9af1183b7842986459bc45 /CMakeLists.txt
parentbb811a244567aa8a1522203f15588f4d001b7353 (diff)
downloadllvm-4e9c939312ff73bd0c6a6485fd5f97012f5910fa.tar.gz
llvm-4e9c939312ff73bd0c6a6485fd5f97012f5910fa.tar.bz2
llvm-4e9c939312ff73bd0c6a6485fd5f97012f5910fa.tar.xz
CMake: Get rid of LLVMLibDeps.cmake and export the libraries normally.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@113632 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a6099d17c5..8a0d9e3e2e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -263,6 +263,7 @@ add_subdirectory(lib/System)
# Everything else depends on Support and System:
set(LLVM_COMMON_DEPENDS ${LLVM_COMMON_DEPENDS} ${LLVM_LIBS} )
+set(LLVM_COMMON_LIBS LLVMSupport LLVMSystem)
set(LLVM_TABLEGEN "tblgen" CACHE
STRING "Native TableGen executable. Saves building one when cross-compiling.")
@@ -362,6 +363,11 @@ add_subdirectory(examples)
add_subdirectory(cmake/modules)
+install(EXPORT LLVM
+ DESTINATION lib${LLVM_LIBDIR_SUFFIX}/cmake/llvm/
+ FILE LLVMTargets.cmake
+ )
+
install(DIRECTORY include/
DESTINATION include
FILES_MATCHING