summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a6099d17c5..8a0d9e3e2e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -263,6 +263,7 @@ add_subdirectory(lib/System)
# Everything else depends on Support and System:
set(LLVM_COMMON_DEPENDS ${LLVM_COMMON_DEPENDS} ${LLVM_LIBS} )
+set(LLVM_COMMON_LIBS LLVMSupport LLVMSystem)
set(LLVM_TABLEGEN "tblgen" CACHE
STRING "Native TableGen executable. Saves building one when cross-compiling.")
@@ -362,6 +363,11 @@ add_subdirectory(examples)
add_subdirectory(cmake/modules)
+install(EXPORT LLVM
+ DESTINATION lib${LLVM_LIBDIR_SUFFIX}/cmake/llvm/
+ FILE LLVMTargets.cmake
+ )
+
install(DIRECTORY include/
DESTINATION include
FILES_MATCHING