summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastian Pop <spop@codeaurora.org>2012-08-08 18:04:45 +0000
committerSebastian Pop <spop@codeaurora.org>2012-08-08 18:04:45 +0000
commit9469dd3a717a0dbe45bf668903ed804f27028b0a (patch)
tree14e39d0544e28102b8831c3de2a7c1796d64f3b9 /CMakeLists.txt
parent6174fd7ed09e9d183d84fb3485a714c5b0c67e4a (diff)
downloadllvm-9469dd3a717a0dbe45bf668903ed804f27028b0a.tar.gz
llvm-9469dd3a717a0dbe45bf668903ed804f27028b0a.tar.bz2
llvm-9469dd3a717a0dbe45bf668903ed804f27028b0a.tar.xz
revert my previous patch
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@161505 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 2 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a3aee58d8d..ed230aee5b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -116,15 +116,8 @@ option(LLVM_ENABLE_FFI "Use libffi to call external functions from the interpret
set(FFI_LIBRARY_DIR "" CACHE PATH "Additional directory, where CMake should search for libffi.so")
set(FFI_INCLUDE_DIR "" CACHE PATH "Additional directory, where CMake should search for ffi.h or ffi/ffi.h")
-set(LLVM_TARGET_ARCH "host" CACHE STRING
- "Set target to use for LLVM JIT or use \"host\" for automatic detection.")
-
-# By default, we target the host, but this can be overridden at CMake
-# invocation time.
-set(LLVM_DEFAULT_TARGET_TRIPLE "${LLVM_TARGET_ARCH}" CACHE STRING
- "Default target for which LLVM will generate code." )
-set(TARGET_TRIPLE "${LLVM_DEFAULT_TARGET_TRIPLE}" CACHE STRING
- "Default target for which LLVM will generate code." )
+set(LLVM_TARGET_ARCH "host"
+ CACHE STRING "Set target to use for LLVM JIT or use \"host\" for automatic detection.")
option(LLVM_ENABLE_THREADS "Use threads if available." ON)