summaryrefslogtreecommitdiff
path: root/lib/CodeGen/CMakeLists.txt
diff options
context:
space:
mode:
authorJakob Stoklund Olesen <stoklund@2pi.dk>2010-04-21 18:02:42 +0000
committerJakob Stoklund Olesen <stoklund@2pi.dk>2010-04-21 18:02:42 +0000
commit00207237ddfffe93b275914d086a0c7da1bbf63b (patch)
tree2537086a8c3260ab79ed5ff6094bedd0ce3228cd /lib/CodeGen/CMakeLists.txt
parent9cdb4109d5fbbff3b881d3288a6ec518abc7712e (diff)
downloadllvm-00207237ddfffe93b275914d086a0c7da1bbf63b.tar.gz
llvm-00207237ddfffe93b275914d086a0c7da1bbf63b.tar.bz2
llvm-00207237ddfffe93b275914d086a0c7da1bbf63b.tar.xz
Add fast register allocator, enabled with -regalloc=fast.
So far this is just a clone of -regalloc=local that has been lobotomized to run 25% faster. It drops the least-recently-used calculations, and is just plain stupid when it runs out of registers. The plan is to make this go even faster for -O0 by taking advantage of the short live intervals in unoptimized code. It should not be necessary to calculate liveness when most virtual registers are killed 2-3 instructions after they are born. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@102006 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CodeGen/CMakeLists.txt')
-rw-r--r--lib/CodeGen/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/CodeGen/CMakeLists.txt b/lib/CodeGen/CMakeLists.txt
index 9802423105..3e38872a36 100644
--- a/lib/CodeGen/CMakeLists.txt
+++ b/lib/CodeGen/CMakeLists.txt
@@ -50,6 +50,7 @@ add_llvm_library(LLVMCodeGen
ProcessImplicitDefs.cpp
PrologEpilogInserter.cpp
PseudoSourceValue.cpp
+ RegAllocFast.cpp
RegAllocLinearScan.cpp
RegAllocLocal.cpp
RegAllocPBQP.cpp