summaryrefslogtreecommitdiff
path: root/lib/CodeGen/CMakeLists.txt
diff options
context:
space:
mode:
authorJakob Stoklund Olesen <stoklund@2pi.dk>2012-11-28 02:35:09 +0000
committerJakob Stoklund Olesen <stoklund@2pi.dk>2012-11-28 02:35:09 +0000
commit11fad6ec660d2131e040ebdecc4433b359d05e5f (patch)
tree731026d366cd89def576dc58dcc74e88d3452f77 /lib/CodeGen/CMakeLists.txt
parent6e1c4561e54da1f9d7052bcb4d985de513b4859c (diff)
downloadllvm-11fad6ec660d2131e040ebdecc4433b359d05e5f.tar.gz
llvm-11fad6ec660d2131e040ebdecc4433b359d05e5f.tar.bz2
llvm-11fad6ec660d2131e040ebdecc4433b359d05e5f.tar.xz
Move Target{Instr,Register}Info.cpp into lib/CodeGen.
The Target library is not allowed to depend on the large CodeGen library, but the TRI and TII classes provide abstract interfaces that require both caller and callee to link to CodeGen. The implementation files for these classes provide default implementations of some of the hooks. These methods may need to reference CodeGen, so they belong in that library. We already have a number of methods implemented in the TargetInstrInfoImpl sub-class because of that. I will merge that class into the parent next. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@168758 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CodeGen/CMakeLists.txt')
-rw-r--r--lib/CodeGen/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/lib/CodeGen/CMakeLists.txt b/lib/CodeGen/CMakeLists.txt
index 7a20ff631e..3039242203 100644
--- a/lib/CodeGen/CMakeLists.txt
+++ b/lib/CodeGen/CMakeLists.txt
@@ -99,9 +99,11 @@ add_llvm_library(LLVMCodeGen
StrongPHIElimination.cpp
TailDuplication.cpp
TargetFrameLoweringImpl.cpp
+ TargetInstrInfo.cpp
TargetInstrInfoImpl.cpp
TargetLoweringObjectFileImpl.cpp
TargetOptionsImpl.cpp
+ TargetRegisterInfo.cpp
TargetSchedule.cpp
TwoAddressInstructionPass.cpp
UnreachableBlockElim.cpp