summaryrefslogtreecommitdiff
path: root/lib/CompilerDriver/CMakeLists.txt
diff options
context:
space:
mode:
authorMikhail Glushenkov <foldr@codedgers.com>2009-03-02 09:01:14 +0000
committerMikhail Glushenkov <foldr@codedgers.com>2009-03-02 09:01:14 +0000
commitf188178a2f8e6452d3e161acdad9a79e1f36c43f (patch)
treede8d87fb2706a89f24bc57ce512955909645eecc /lib/CompilerDriver/CMakeLists.txt
parent99dac47b0abfaf40c36822a11310b43e95654e50 (diff)
downloadllvm-f188178a2f8e6452d3e161acdad9a79e1f36c43f.tar.gz
llvm-f188178a2f8e6452d3e161acdad9a79e1f36c43f.tar.bz2
llvm-f188178a2f8e6452d3e161acdad9a79e1f36c43f.tar.xz
Reorganize llvmc code.
Move the code from 'llvmc/driver' into a new CompilerDriver library, and change the build system accordingly. Makes it easier for projects using LLVM to build their own llvmc-based drivers. Tested with objdir != srcdir. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@65821 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CompilerDriver/CMakeLists.txt')
-rw-r--r--lib/CompilerDriver/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/lib/CompilerDriver/CMakeLists.txt b/lib/CompilerDriver/CMakeLists.txt
new file mode 100644
index 0000000000..153dd443cb
--- /dev/null
+++ b/lib/CompilerDriver/CMakeLists.txt
@@ -0,0 +1,10 @@
+set(LLVM_LINK_COMPONENTS support system)
+set(LLVM_REQUIRES_EH 1)
+
+add_llvm_tool(llvmc
+ Action.cpp
+ CompilationGraph.cpp
+ llvmc.cpp
+ Plugin.cpp
+ Tool.cpp
+ )