summaryrefslogtreecommitdiff
path: root/lib/CompilerDriver/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/CompilerDriver/CMakeLists.txt')
-rw-r--r--lib/CompilerDriver/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/lib/CompilerDriver/CMakeLists.txt b/lib/CompilerDriver/CMakeLists.txt
new file mode 100644
index 0000000000..153dd443cb
--- /dev/null
+++ b/lib/CompilerDriver/CMakeLists.txt
@@ -0,0 +1,10 @@
+set(LLVM_LINK_COMPONENTS support system)
+set(LLVM_REQUIRES_EH 1)
+
+add_llvm_tool(llvmc
+ Action.cpp
+ CompilationGraph.cpp
+ llvmc.cpp
+ Plugin.cpp
+ Tool.cpp
+ )