summaryrefslogtreecommitdiff
path: root/lib/MC/CMakeLists.txt
diff options
context:
space:
mode:
authorTim Northover <tnorthover@apple.com>2014-03-29 07:34:53 +0000
committerTim Northover <tnorthover@apple.com>2014-03-29 07:34:53 +0000
commit1330ee3189a3a29ce89fc2648e6a0d98ba36f0d4 (patch)
tree1f383ae419136fd28c8d6b8f61910edabd11e8df /lib/MC/CMakeLists.txt
parent0301154c0edc86816e995c9847a4e3f2856c2dad (diff)
downloadllvm-1330ee3189a3a29ce89fc2648e6a0d98ba36f0d4.tar.gz
llvm-1330ee3189a3a29ce89fc2648e6a0d98ba36f0d4.tar.bz2
llvm-1330ee3189a3a29ce89fc2648e6a0d98ba36f0d4.tar.xz
MachO: Add linker-optimisation hint framework to MC.
Another part of the ARM64 backend (so tests will be following soon). This is currently used by the linker to relax adrp/ldr pairs into nops where possible, though could well be more broadly applicable. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@205084 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/MC/CMakeLists.txt')
-rw-r--r--lib/MC/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/MC/CMakeLists.txt b/lib/MC/CMakeLists.txt
index eb3f9e52d7..ab7dabc9c7 100644
--- a/lib/MC/CMakeLists.txt
+++ b/lib/MC/CMakeLists.txt
@@ -24,6 +24,7 @@ add_llvm_library(LLVMMC
MCInstPrinter.cpp
MCInstrAnalysis.cpp
MCLabel.cpp
+ MCLinkerOptimizationHint.cpp
MCMachOStreamer.cpp
MCMachObjectTargetWriter.cpp
MCModule.cpp