summaryrefslogtreecommitdiff
path: root/lib/Target/Mips/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Lattner <sabre@nondot.org>2010-11-14 18:43:56 +0000
committerChris Lattner <sabre@nondot.org>2010-11-14 18:43:56 +0000
commit1139691e3aadff751c035f38f835d436ec6cf10a (patch)
tree8287424f01072c252a61fe2a95498f545bf21b3e /lib/Target/Mips/CMakeLists.txt
parenteff0581583ef10e2872e9baf537a04b67d992101 (diff)
downloadllvm-1139691e3aadff751c035f38f835d436ec6cf10a.tar.gz
llvm-1139691e3aadff751c035f38f835d436ec6cf10a.tar.bz2
llvm-1139691e3aadff751c035f38f835d436ec6cf10a.tar.xz
move all the target's asmprinters into the main target. The piece
that should be split out is the InstPrinter (if a target is mc'ized). This change makes all the targets be consistent. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@119056 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/Mips/CMakeLists.txt')
-rw-r--r--lib/Target/Mips/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Target/Mips/CMakeLists.txt b/lib/Target/Mips/CMakeLists.txt
index 78767e52e1..dda6da9fc3 100644
--- a/lib/Target/Mips/CMakeLists.txt
+++ b/lib/Target/Mips/CMakeLists.txt
@@ -11,6 +11,7 @@ tablegen(MipsGenCallingConv.inc -gen-callingconv)
tablegen(MipsGenSubtarget.inc -gen-subtarget)
add_llvm_target(MipsCodeGen
+ MipsAsmPrinter.cpp
MipsDelaySlotFiller.cpp
MipsInstrInfo.cpp
MipsISelDAGToDAG.cpp