summaryrefslogtreecommitdiff
path: root/tools/gold/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2011-05-12 11:26:21 +0000
committerOscar Fuentes <ofv@wanadoo.es>2011-05-12 11:26:21 +0000
commitbe5d9b0bdcc47fc022e2bc6e75c0977f782b2dd1 (patch)
tree8597e604a35fa7e92f306cc80b51b732ae0b0d11 /tools/gold/CMakeLists.txt
parentcbc988be22bc9411d95215c8b7251b5f85710674 (diff)
downloadllvm-be5d9b0bdcc47fc022e2bc6e75c0977f782b2dd1.tar.gz
llvm-be5d9b0bdcc47fc022e2bc6e75c0977f782b2dd1.tar.bz2
llvm-be5d9b0bdcc47fc022e2bc6e75c0977f782b2dd1.tar.xz
CMake builds gold by default since revision 127466. This is
inconsistent with autoconf, which by default set BINUTILS_INCDIR to empty and exclude gold from target list. Based on a patch by Haitao Li! git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@131229 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/gold/CMakeLists.txt')
-rw-r--r--tools/gold/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/tools/gold/CMakeLists.txt b/tools/gold/CMakeLists.txt
index d8633e6e47..eb4b6e6aae 100644
--- a/tools/gold/CMakeLists.txt
+++ b/tools/gold/CMakeLists.txt
@@ -1,7 +1,9 @@
-set(LLVM_BINUTILS_INCDIR "/usr/include" CACHE PATH
+set(LLVM_BINUTILS_INCDIR "" CACHE PATH
"PATH to binutils/include containing plugin-api.h for gold plugin.")
-if( NOT EXISTS "${LLVM_BINUTILS_INCDIR}/plugin-api.h" )
+if( NOT LLVM_BINUTILS_INCDIR )
+ # Nothing to say.
+elseif( NOT EXISTS "${LLVM_BINUTILS_INCDIR}/plugin-api.h" )
message(STATUS "plugin-api.h not found. gold plugin excluded from the build.")
else()
include_directories( ${LLVM_BINUTILS_INCDIR} )