summaryrefslogtreecommitdiff
path: root/tools/llvm-ar/CMakeLists.txt
diff options
context:
space:
mode:
authorRafael Espindola <rafael.espindola@gmail.com>2013-07-12 20:21:39 +0000
committerRafael Espindola <rafael.espindola@gmail.com>2013-07-12 20:21:39 +0000
commit34ac52d9377b104c83f80184f284199d68732f07 (patch)
tree90a9245e96c8cc8e429b785d6e13fef59f35c779 /tools/llvm-ar/CMakeLists.txt
parent795740b591331a0caf342edc4d572ec348415b40 (diff)
downloadllvm-34ac52d9377b104c83f80184f284199d68732f07.tar.gz
llvm-34ac52d9377b104c83f80184f284199d68732f07.tar.bz2
llvm-34ac52d9377b104c83f80184f284199d68732f07.tar.xz
Change llvm-ar to use lib/Object.
This fixes two bugs is lib/Object that the use in llvm-ar found: * In OS X created archives, the name can be padded with nulls. Strip them. * In the constructor, remember the first non special member and use that in begin_children. This makes sure we skip all special members, not just the first one. The change to llvm-ar itself consist of * Using lib/Object for reading archives instead of ArchiveReader.cpp. * Writing the modified archive directly, instead of creating an in memory representation. The old Archive library was way more general than what is needed, as can be seen by the diffstat of this patch. Having llvm-ar using lib/Object now opens the way for creating regular symbol tables for both native objects and bitcode files so that we can use those archives for LTO. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@186197 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/llvm-ar/CMakeLists.txt')
-rw-r--r--tools/llvm-ar/CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/tools/llvm-ar/CMakeLists.txt b/tools/llvm-ar/CMakeLists.txt
index 68095df714..503999c262 100644
--- a/tools/llvm-ar/CMakeLists.txt
+++ b/tools/llvm-ar/CMakeLists.txt
@@ -1,10 +1,7 @@
-set(LLVM_LINK_COMPONENTS support bitreader)
+set(LLVM_LINK_COMPONENTS support object bitreader)
add_llvm_tool(llvm-ar
llvm-ar.cpp
- ArchiveWriter.cpp
- ArchiveReader.cpp
- Archive.cpp
)
# TODO: Support check-local.