summaryrefslogtreecommitdiff
path: root/tools/msbuild/CMakeLists.txt
diff options
context:
space:
mode:
authorReid Kleckner <reid@kleckner.net>2013-08-29 22:09:43 +0000
committerReid Kleckner <reid@kleckner.net>2013-08-29 22:09:43 +0000
commit002062b024c094279d4b0ed7db13a69159b2d8ba (patch)
tree3d2b9e39fc7a3fc74edfaa671a6c2cf04a552a89 /tools/msbuild/CMakeLists.txt
parent6d3bbc05a79c5bfe1e7a17acb913d8d09c45b50b (diff)
downloadllvm-002062b024c094279d4b0ed7db13a69159b2d8ba.tar.gz
llvm-002062b024c094279d4b0ed7db13a69159b2d8ba.tar.bz2
llvm-002062b024c094279d4b0ed7db13a69159b2d8ba.tar.xz
Substitute LLVM's version into the msbuild property file at config time
Requires shuffling the CPack code up before add_subdirectory(tools), but that's where the version settings are anyway. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@189615 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/msbuild/CMakeLists.txt')
-rw-r--r--tools/msbuild/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/tools/msbuild/CMakeLists.txt b/tools/msbuild/CMakeLists.txt
index a1dca8aca8..393b22a72c 100644
--- a/tools/msbuild/CMakeLists.txt
+++ b/tools/msbuild/CMakeLists.txt
@@ -1,9 +1,15 @@
if (WIN32)
+ set(prop_file "Microsoft.Cpp.Win32.llvm.props")
+
+ # CPack will install a registry key in this format that we wish to reference.
+ set(REG_KEY "${CMAKE_PROJECT_NAME} ${CPACK_PACKAGE_VERSION}")
+ configure_file(${prop_file}.in ${prop_file})
+ install(FILES "${CMAKE_CURRENT_BINARY_DIR}/${prop_file}" DESTINATION tools/msbuild)
+
install(DIRECTORY .
DESTINATION tools/msbuild
FILES_MATCHING
PATTERN "*.targets"
- PATTERN "*.props"
PATTERN "*.bat"
PATTERN ".svn" EXCLUDE
)