summaryrefslogtreecommitdiff
path: root/tools/msbuild/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/msbuild/CMakeLists.txt')
-rw-r--r--tools/msbuild/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/tools/msbuild/CMakeLists.txt b/tools/msbuild/CMakeLists.txt
index a1dca8aca8..393b22a72c 100644
--- a/tools/msbuild/CMakeLists.txt
+++ b/tools/msbuild/CMakeLists.txt
@@ -1,9 +1,15 @@
if (WIN32)
+ set(prop_file "Microsoft.Cpp.Win32.llvm.props")
+
+ # CPack will install a registry key in this format that we wish to reference.
+ set(REG_KEY "${CMAKE_PROJECT_NAME} ${CPACK_PACKAGE_VERSION}")
+ configure_file(${prop_file}.in ${prop_file})
+ install(FILES "${CMAKE_CURRENT_BINARY_DIR}/${prop_file}" DESTINATION tools/msbuild)
+
install(DIRECTORY .
DESTINATION tools/msbuild
FILES_MATCHING
PATTERN "*.targets"
- PATTERN "*.props"
PATTERN "*.bat"
PATTERN ".svn" EXCLUDE
)