summaryrefslogtreecommitdiff
path: root/tools/msbuild/CMakeLists.txt
diff options
context:
space:
mode:
authorHans Wennborg <hans@hanshq.net>2013-09-06 17:05:46 +0000
committerHans Wennborg <hans@hanshq.net>2013-09-06 17:05:46 +0000
commit1bcff6cffa30c2fdcf0eac80ef9551429b38f25d (patch)
tree64fb332684a5613d7bba96bae2b090b32b206ab4 /tools/msbuild/CMakeLists.txt
parentb63db853500b3dcb46a96af3f2d5aec003e41d77 (diff)
downloadllvm-1bcff6cffa30c2fdcf0eac80ef9551429b38f25d.tar.gz
llvm-1bcff6cffa30c2fdcf0eac80ef9551429b38f25d.tar.bz2
llvm-1bcff6cffa30c2fdcf0eac80ef9551429b38f25d.tar.xz
msbuild integration: provide separate files for VS2010 and VS2012
The previous msbuild integration only worked if VS2010 was installed. This patch renames the current integration to LLVM-vs2010 and adds LLVM-vs2012. Differential Revision: http://llvm-reviews.chandlerc.com/D1614 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@190173 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/msbuild/CMakeLists.txt')
-rw-r--r--tools/msbuild/CMakeLists.txt18
1 files changed, 14 insertions, 4 deletions
diff --git a/tools/msbuild/CMakeLists.txt b/tools/msbuild/CMakeLists.txt
index 393b22a72c..860ed22526 100644
--- a/tools/msbuild/CMakeLists.txt
+++ b/tools/msbuild/CMakeLists.txt
@@ -1,10 +1,20 @@
if (WIN32)
- set(prop_file "Microsoft.Cpp.Win32.llvm.props")
+ set(prop_file_in "Microsoft.Cpp.Win32.llvm.props.in")
+ set(prop_file_v100 "Microsoft.Cpp.Win32.LLVM-vs2010.props")
+ set(prop_file_v110 "Microsoft.Cpp.Win32.LLVM-vs2012.props")
# CPack will install a registry key in this format that we wish to reference.
set(REG_KEY "${CMAKE_PROJECT_NAME} ${CPACK_PACKAGE_VERSION}")
- configure_file(${prop_file}.in ${prop_file})
- install(FILES "${CMAKE_CURRENT_BINARY_DIR}/${prop_file}" DESTINATION tools/msbuild)
+
+ set(VS_VERSION "v100")
+ configure_file(${prop_file_in} ${prop_file_v100})
+ set(VS_VERSION "v110")
+ configure_file(${prop_file_in} ${prop_file_v110})
+
+ set(REG_KEY)
+ set(VS_VERSION)
+ install(FILES "${CMAKE_CURRENT_BINARY_DIR}/${prop_file_v100}" DESTINATION tools/msbuild)
+ install(FILES "${CMAKE_CURRENT_BINARY_DIR}/${prop_file_v110}" DESTINATION tools/msbuild)
install(DIRECTORY .
DESTINATION tools/msbuild
@@ -13,4 +23,4 @@ if (WIN32)
PATTERN "*.bat"
PATTERN ".svn" EXCLUDE
)
-endif()
+endif()