summaryrefslogtreecommitdiff
path: root/tools/msbuild/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/msbuild/CMakeLists.txt')
-rw-r--r--tools/msbuild/CMakeLists.txt18
1 files changed, 14 insertions, 4 deletions
diff --git a/tools/msbuild/CMakeLists.txt b/tools/msbuild/CMakeLists.txt
index 393b22a72c..860ed22526 100644
--- a/tools/msbuild/CMakeLists.txt
+++ b/tools/msbuild/CMakeLists.txt
@@ -1,10 +1,20 @@
if (WIN32)
- set(prop_file "Microsoft.Cpp.Win32.llvm.props")
+ set(prop_file_in "Microsoft.Cpp.Win32.llvm.props.in")
+ set(prop_file_v100 "Microsoft.Cpp.Win32.LLVM-vs2010.props")
+ set(prop_file_v110 "Microsoft.Cpp.Win32.LLVM-vs2012.props")
# CPack will install a registry key in this format that we wish to reference.
set(REG_KEY "${CMAKE_PROJECT_NAME} ${CPACK_PACKAGE_VERSION}")
- configure_file(${prop_file}.in ${prop_file})
- install(FILES "${CMAKE_CURRENT_BINARY_DIR}/${prop_file}" DESTINATION tools/msbuild)
+
+ set(VS_VERSION "v100")
+ configure_file(${prop_file_in} ${prop_file_v100})
+ set(VS_VERSION "v110")
+ configure_file(${prop_file_in} ${prop_file_v110})
+
+ set(REG_KEY)
+ set(VS_VERSION)
+ install(FILES "${CMAKE_CURRENT_BINARY_DIR}/${prop_file_v100}" DESTINATION tools/msbuild)
+ install(FILES "${CMAKE_CURRENT_BINARY_DIR}/${prop_file_v110}" DESTINATION tools/msbuild)
install(DIRECTORY .
DESTINATION tools/msbuild
@@ -13,4 +23,4 @@ if (WIN32)
PATTERN "*.bat"
PATTERN ".svn" EXCLUDE
)
-endif()
+endif()