summaryrefslogtreecommitdiff
path: root/unittests/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael J. Spencer <bigcheesegs@gmail.com>2010-10-11 21:22:34 +0000
committerMichael J. Spencer <bigcheesegs@gmail.com>2010-10-11 21:22:34 +0000
commit12647eb3f529880e882c9bc5cb88ffdbf51f851f (patch)
treeb9571e273e1396ee46ec24e8e46917464c4e261b /unittests/CMakeLists.txt
parent5031e0d97709658d552e33b2f5bd8957b4e6171e (diff)
downloadllvm-12647eb3f529880e882c9bc5cb88ffdbf51f851f.tar.gz
llvm-12647eb3f529880e882c9bc5cb88ffdbf51f851f.tar.bz2
llvm-12647eb3f529880e882c9bc5cb88ffdbf51f851f.tar.xz
Reduce dpendencies for SupportTests.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@116235 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/CMakeLists.txt')
-rw-r--r--unittests/CMakeLists.txt32
1 files changed, 19 insertions, 13 deletions
diff --git a/unittests/CMakeLists.txt b/unittests/CMakeLists.txt
index 2337fe25ef..8a5a367794 100644
--- a/unittests/CMakeLists.txt
+++ b/unittests/CMakeLists.txt
@@ -66,6 +66,25 @@ add_llvm_unittest(JIT
ExecutionEngine/JIT/MultiJITTest.cpp
)
+add_llvm_unittest(Transforms
+ Transforms/Utils/Cloning.cpp
+ )
+
+add_llvm_unittest(VMCore
+ VMCore/ConstantsTest.cpp
+ VMCore/DerivedTypesTest.cpp
+ VMCore/InstructionsTest.cpp
+ VMCore/MetadataTest.cpp
+ VMCore/PassManagerTest.cpp
+ VMCore/VerifierTest.cpp
+ )
+
+set(LLVM_LINK_COMPONENTS
+ System
+ Support
+ Core
+ )
+
add_llvm_unittest(Support
Support/AllocatorTest.cpp
Support/Casting.cpp
@@ -80,16 +99,3 @@ add_llvm_unittest(Support
Support/TypeBuilderTest.cpp
Support/ValueHandleTest.cpp
)
-
-add_llvm_unittest(Transforms
- Transforms/Utils/Cloning.cpp
- )
-
-add_llvm_unittest(VMCore
- VMCore/ConstantsTest.cpp
- VMCore/DerivedTypesTest.cpp
- VMCore/InstructionsTest.cpp
- VMCore/MetadataTest.cpp
- VMCore/PassManagerTest.cpp
- VMCore/VerifierTest.cpp
- )