summaryrefslogtreecommitdiff
path: root/lib/CodeGen/CMakeLists.txt
diff options
context:
space:
mode:
authorJakob Stoklund Olesen <stoklund@2pi.dk>2012-11-28 02:35:13 +0000
committerJakob Stoklund Olesen <stoklund@2pi.dk>2012-11-28 02:35:13 +0000
commitfa2d98632c77e5d9c305e97e5fa25d06f579127b (patch)
treef9660d42a520e4fd70a22a9c0e3f3c986d66775d /lib/CodeGen/CMakeLists.txt
parent11fad6ec660d2131e040ebdecc4433b359d05e5f (diff)
downloadllvm-fa2d98632c77e5d9c305e97e5fa25d06f579127b.tar.gz
llvm-fa2d98632c77e5d9c305e97e5fa25d06f579127b.tar.bz2
llvm-fa2d98632c77e5d9c305e97e5fa25d06f579127b.tar.xz
Move the guts of TargetInstrInfoImpl into the TargetInstrInfo class.
The *Impl class no longer serves a purpose now that the super-class implementation is in CodeGen. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@168759 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CodeGen/CMakeLists.txt')
-rw-r--r--lib/CodeGen/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/lib/CodeGen/CMakeLists.txt b/lib/CodeGen/CMakeLists.txt
index 3039242203..1e08672183 100644
--- a/lib/CodeGen/CMakeLists.txt
+++ b/lib/CodeGen/CMakeLists.txt
@@ -100,7 +100,6 @@ add_llvm_library(LLVMCodeGen
TailDuplication.cpp
TargetFrameLoweringImpl.cpp
TargetInstrInfo.cpp
- TargetInstrInfoImpl.cpp
TargetLoweringObjectFileImpl.cpp
TargetOptionsImpl.cpp
TargetRegisterInfo.cpp